New zx7 knocking when warm - Kawasaki Forum :: KawasakiWorld.com
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-23-2015, 12:13 AM Thread Starter
Junior Member
 
Join Date: Oct 2015
Location: Gloucestershire
Posts: 2
New zx7 knocking when warm

Hi,

I've just purchased a zx7 97 P2 I think. it has 29k with no history.
On first inspection the bike seems and rides fine but today I have noticed something I don't like.

Riding the bike normally with revs under 5k the bike sounds like a zx7, if I give some beans and rev over 5k (Only when warm) I can hear a knocking/thumping noise from the engine. It seems like its coming from the front of the engine. Also and may not be related its happened a few times, it seems to pop/ping one big noise like exhaust backfire but comes from the engine. again this has only happened a couple of times.

I have changed the oil, 10w40 semi, new filter. it was missing the top cam chain guide so fitted a new one. looked like it had been hitting the top studs.


Anyway, Any information you can give me would be great. Anything I can check myself to keep the repair bill down too.

thanks in advance.
Paddy
TwoWheelAction is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-23-2015, 04:19 AM
Senior Member
 
Ken12r's Avatar
 
Join Date: Apr 2011
Location: England
Posts: 238
You are not going to get the correct answer on here because there are so many possible things that can go wrong on an 18 year old bike and most of it is going to be guesses and speculation.
So my suggestion is you take it to someone who knows Kawasakis in your area like Tim Blakemore in Bristol to get an accurate answer.
Ken12r is offline  
post #3 of 4 Old 10-26-2015, 01:45 AM Thread Starter
Junior Member
 
Join Date: Oct 2015
Location: Gloucestershire
Posts: 2
Thank you for the advice
TwoWheelAction is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 04-20-2016, 04:32 PM
Junior Member
 
Join Date: Apr 2016
Location: Topeka,ks
Posts: 16
I had a p2 with same milage with a knocking sound..I swear it was metal on metal, but under inspection I was told to check my headers and sure enough they were lose..tightened them up and knock went away..fingures crossed for you
forfun785 is offline  
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki Motorcycles > ZX-7R

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
warm front coming through! greenyzx12r2003 ZX-12R 19 03-11-2003 04:57 AM
warm thanks greenyzx12r2003 ZX-12R 2 12-29-2002 06:52 PM
Warm up cycle ???? Avenger ZX-12R 18 09-29-2002 05:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome