Help! 2006 zx14 instrument cluster - Kawasaki Forum :: KawasakiWorld.com
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-26-2015, 05:13 PM Thread Starter
Junior Member
 
Join Date: Nov 2015
Location: gilbert az.
Posts: 1
Help! 2006 zx14 instrument cluster

OK GUYS HERES THE ISSUE 2006 zx14 13k miles just put a new battery not new but new to bike and in working order. had frame changed out by a hack ( only realized the hack part when i got bike back). stuff was loose etc. as i was going down the road the instrument cluster lights started flickering on off this went on for a bit then completly off. the speedo and tach dont work nor do they resett when ignition key on as they used to peg then return and function once bike running. they will resett if i disconnect battery and or the main plug in back of cluster. the blinker and high beam lights and all lights in there factory locaions work fine ie. brake blinker stop etc. is it possible only part of the cluster to fail? ive went over all wiring and connections. not i do have a dyno jet power commander V installed if thst makes a differemce
zx14fatty is offline  
Sponsored Links
Advertisement
 
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki Motorcycles > ZX-14

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can ya change instrument cluster with problems??? GIxxer2110 ZX-12R 10 07-22-2015 02:47 AM
Instrument cluster bulbs zx12r terry tibbs ZX-12R 6 04-22-2014 01:13 AM
05 Instrument Cluster Key Symbol shiggsy ZX-12R 3 11-06-2010 03:33 AM
Looking for instrument cluster (ZX12R) LeanRider ZX-12R 1 06-17-2006 06:02 PM
taking dials off (instrument cluster) bluedraco ZX-12R 8 09-23-2004 12:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome