Fuel pump not priming after replacing stator - Kawasaki Forum :: KawasakiWorld.com
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 04-19-2017, 10:19 AM Thread Starter
Junior Member
 
QDL62's Avatar
 
Join Date: Apr 2017
Location: Cheshire
Posts: 3
Garage
Fuel pump not priming after replacing stator

Stator burnt out, so replaced it. The bike started with old stator but wires got hot. now I have replaced stator I turn on ignition all lights on dash working ok neddles move and reset as it should but now the bike will not start. I cant here the pump priming (little wizzy noise when you turn on ignition. I checked the regulator and it appears ok but have ordered a new one anyway. Any ideas.....
QDL62 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-19-2017, 01:51 PM
Senior Member
 
dastardly's Avatar
 
Join Date: Aug 2014
Location: australia
Posts: 814
Hi QGL62 check all the fuses hope its an easy fix Craig

if anything goes wrong check the battery
B1 black and "GOLD"
dastardly is offline  
post #3 of 6 Old 04-20-2017, 01:12 AM Thread Starter
Junior Member
 
QDL62's Avatar
 
Join Date: Apr 2017
Location: Cheshire
Posts: 3
Garage
All fuses are good. Thought it might be datatool alarm so linked it out but it is not that. Spent a whole day checking all the plugs n sockets to see if I had disturbed one when installing stator cable and cant find any that were open.
QDL62 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 04-20-2017, 02:01 AM
Senior Member
 
ninjayorkie's Avatar
 
Join Date: Dec 2004
Location: Altofts zx12B4
Posts: 1,167
Garage
You don't say which model you have, as there are wiring differences, but the guides on the zx9 site are more or less the same switches. ok, Your garage picture shows an A1 so the zx9 wirings the same. if you cant see the pictures click on the place holder.

Clutch lever switch, try starting with clutch lever pulled in.
Kill Switch or start button dirty contacts.

Clutch switch checking and cleaning zx-9r.net ? View topic - Clutch switch checking, cleaning and/or replacing.

Kill Switch Start button cleaning zx-9r.net ? View topic - How to strip and clean the start button and kill switch.

For Tech Questions Bike Model letters are more useful than saying the year, for uk owners anyway, as registration year is not always year of manufacturer model.

Last edited by ninjayorkie; 04-20-2017 at 02:04 AM.
ninjayorkie is offline  
post #5 of 6 Old 04-20-2017, 04:08 AM
Senior Member
 
dastardly's Avatar
 
Join Date: Aug 2014
Location: australia
Posts: 814
yeah Im with ninjayorkie check the clutch switch, not sure how it effects pump, but if the switch is not working try starting in N out of gear don't touch the clutch and see if it works Craig

if anything goes wrong check the battery
B1 black and "GOLD"
dastardly is offline  
post #6 of 6 Old 04-20-2017, 07:35 AM Thread Starter
Junior Member
 
QDL62's Avatar
 
Join Date: Apr 2017
Location: Cheshire
Posts: 3
Garage
Sorry forgot to mention it was a n A1. Many thanks for the advice been at Oulton Park watching BSB testing so will try these things tomorrow and lwet you know how I got on. I say the strange thing is that I changed the stator in a day and it started with old knackered one and was mortified when after putting new one in it would not start. But I will post the result of work tomorrow.
QDL62 is offline  
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki Motorcycles > ZX-12R

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel pump. seanszx12r ZX-12R 3 04-27-2017 11:39 AM
2000 ZX12R - Electrical Gremlins (maybe ECU) SuperHoon ZX-12R 1 12-19-2016 06:21 AM
Fuel pump ,again !! re-dynoed andy1965 ZX-12R 10 09-25-2016 11:41 AM
2004 Zx12r fuel pump not priming help Resact ZX-12R 4 09-06-2016 02:01 PM
fuel pump and lines question WwDestiny ZX-9R 0 08-05-2016 01:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome