Oil pressure problem - Kawasaki Forum :: KawasakiWorld.com
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-26-2017, 06:19 PM Thread Starter
Senior Member
 
Join Date: Nov 2011
Location: Missouri
Posts: 330
Oil pressure problem

So I changed the oil in bike and used rotella fully synthetic 15w 40. Oil light wouldn't go off found out oil pressure sensor under stator cover wire was broke. So I wrapped spare wire around screw and tightened it then wrapped it with oiled wire. Turned on bike and oil light went off. After getting pretty warm light turns on until i rev it to 2 1/2 it goes off. Tried to take it for a ride whe. Bike gets highway speed and motor gets really hot oil light stays on till 6k rpm. Took it straight home. I'm not sure if it could be from the sensor and the way I hooked it up or something else. I checked oil filter to see if oil pressure seems to be there and started bike and oil shot out. So I'm puzzled any help? Oh and I don't know if this makes a difference but there is a leak on valve cover gasket and stator cover but I already have the stator cover gasket coming in.
Savagerider is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-28-2017, 07:27 AM
Junior Member
 
Join Date: Jun 2010
Location: Robinson Tx.
Posts: 11
Was it working fine before the oil change ? Did you change the filter ? If so I would try another filter . I do not think the leaking valve cover or stator cover would be the problem unless it is pouring out .
richard93lt1 is offline  
post #3 of 3 Old 03-28-2017, 08:54 AM Thread Starter
Senior Member
 
Join Date: Nov 2011
Location: Missouri
Posts: 330
I'm not sure it was messed up when I got it a couple weeks ago I'm just now in the works of putting it together
Savagerider is offline  
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki Motorcycles > ZX-12R

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Where is tgezx12r fuel pressure regulator? Rodney Kemp ZX-12R 2 02-22-2017 06:50 PM
Top speed problem Savagerider ZX-12R 7 11-18-2016 10:32 PM
98 zx6r rear brake problem zaden ZX-6R 0 10-11-2016 10:38 PM
1998 Kawasaki Vulcan 1500 shifting problem spearsjoshua137 Vulcan 0 09-23-2016 09:56 PM
1998 vn1500 classic problem gollum Vulcan 1 08-08-2016 08:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome