Headlight help - Kawasaki Forum :: KawasakiWorld.com
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 03-23-2017, 07:07 PM Thread Starter
Senior Member
 
Join Date: Nov 2011
Location: Missouri
Posts: 329
Headlight help

So the stator cover was broke when I got the bike. I started bike briefly and lights came on. Yesterday I replaced the stator cover and didn't pay attention if lights was on yesterday when bike was running. Well I took bike out today and when I started to get dark I realized the headlight nor the third light on top was working. I tapped the start button to see if it would start working and nothing. Can anyone help me get the lights on or know away around to get them to work
Savagerider is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 03-23-2017, 07:32 PM Thread Starter
Senior Member
 
Join Date: Nov 2011
Location: Missouri
Posts: 329
I don't know if this makes a difference but I see my left controls for the headlight and blinkers don't work. If I tap Fulbright blinker enough it comes on but that's it. I don't know if them controls would keep the headlight from coming on
Savagerider is offline  
post #3 of 5 Old 03-23-2017, 08:38 PM Thread Starter
Senior Member
 
Join Date: Nov 2011
Location: Missouri
Posts: 329
All fuses are good
Savagerider is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 03-27-2017, 05:03 PM
Senior Member
 
wylde's Avatar
 
Join Date: Jul 2005
Location: NYC
Posts: 2,976
Fuse under tank cover, wiggle hi/lo beam switch, check harness plug under wind screen.
wylde is offline  
post #5 of 5 Old 03-28-2017, 03:38 AM
Senior Member
 
ninjayorkie's Avatar
 
Join Date: Dec 2004
Location: Altofts zx12B4
Posts: 1,165
Garage
Quote:
Originally Posted by Savagerider View Post
I don't know if this makes a difference but I see my left controls for the headlight and blinkers don't work. If I tap Fulbright blinker enough it comes on but that's it. I don't know if them controls would keep the headlight from coming on
Time to follow that left hand controller wiring to where it connects to the main loom under the lefthand infill panel. Chances are the plug pins are dirty.

Check the headlight to main loom plug normally behind the clocks, taking the wind screen off makes it easy to get to.

For Tech Questions Bike Model letters are more useful than saying the year, for uk owners anyway, as registration year is not always year of manufacturer model.
ninjayorkie is offline  
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki Motorcycles > ZX-12R

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Left Headlight fogging up Factory ZX-12R 8 03-16-2017 12:43 AM
1999 headlight not working antman25 ZX-9R 6 10-15-2016 07:39 AM
Headlight help Savagerider ZX-12R 2 09-13-2016 08:13 AM
Headlight E2/F1 Tigcraftboy ZX-9R 1 09-06-2016 01:16 AM
What is size light goes into upper headlight BigSkip765 ZX-12R 12 07-27-2016 02:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome