Need help!! Z750s 2005 - gas smell when engine cold - Kawasaki Forum :: KawasakiWorld.com
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 02-13-2017, 04:00 AM Thread Starter
Junior Member
 
gilohayon's Avatar
 
Join Date: Feb 2017
Location: Israel
Posts: 3
Need help!! Z750s 2005 - gas smell when engine cold

Hi everyone , I have a problem with my 2005 z750s , i've got pciiiex , k&n air filter and shorten exhaust.
My bike works extremely rich when cold, strong smell of gas out of the exhaust , the oil level is getting higher.
I've tryed to pull the fi codes but the indicate light stay off.
Someone have an idea?

Sent from my SM-N910F using Tapatalk
gilohayon is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 02-13-2017, 04:52 AM
Member
 
superjoolz's Avatar
 
Join Date: Jun 2010
Location: United kingdom of Great Britain and Northern Ireland
Posts: 34
I'd be tempted to remove the Power Commander completely and see what happens after that.


Sent from my iPhone using Tapatalk
superjoolz is offline  
post #3 of 3 Old 02-13-2017, 04:58 AM Thread Starter
Junior Member
 
gilohayon's Avatar
 
Join Date: Feb 2017
Location: Israel
Posts: 3
Quote:
Originally Posted by superjoolz View Post
I'd be tempted to remove the Power Commander completely and see what happens after that.


Sent from my iPhone using Tapatalk
It behave just the same when i plug out the power comander since i use zero map.

Sent from my SM-N910F using Tapatalk
gilohayon is offline  
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki Motorcycles > Z750 Z1000

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome