P650 work in progress. Need Help - Kawasaki Forum :: KawasakiWorld.com
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-04-2016, 09:02 AM Thread Starter
Junior Member
 
Join Date: Oct 2016
Location: Texas
Posts: 1
P650 work in progress. Need Help

I am restoring an old 2003 P65 to good running condition but now am stumpped.
Starts and idles good
Carbs syncronised by vacuum guages
Fresh fuel
New battery
New Dynatek ignition module
Not in limp mode,no lights flashing
It starts quick and idles good and smooth.However when warmed up to run temp the engine throttle accelleration is a bit slow. It will rev up but sounds odd. Both carb slides open as they should. But the engine revs have a funny or odd sound, not sounding like a good running P650.
The only clue I have to this problem is that the revs are much better and the sound more good by pulling the choke on. This tells me that it is running lean but I dont know where to start looking first. I sure could use some clues. Thanks a BUNCH in advance !!
Sarge in N. Texas
Sarge69 is offline  
Sponsored Links
Advertisement
 
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki World > Off Road

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome