Prairie 650 - Kawasaki Forum :: KawasakiWorld.com
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-19-2012, 05:52 AM Thread Starter
Junior Member
 
Join Date: Apr 2012
Location: VA
Posts: 1
Prairie 650

Hello to all :)

I am working on a Prairie 650, the problem started when it became difficult to shift into Low and Reverse and N the shifter would need to be between H & R in order for it to kick in. So I started with the adjustment of the linkage, I had it adjusted to where N was where it should be in the shifter slot and H was good and L seemed to kick in well, but was still having trouble with R it still wanted to grind a little. I decided to turn it off and do some more adjusting for R. After I adjusted it the N light would not come on, so I pull started it and now it will not go into R,N or L. It seems to be stuck in High. Where did I go wrong? While I was letting it cool down after the last adjustment I vacumed some of the crap off the electronics under the seat since it was a mess, could I have lost a connection there that would cause this? I'm not getting a "belt" light so I dont think it has went into "limp mode".
mike1346 is offline  
Sponsored Links
Advertisement
 
Reply

  Kawasaki Forum :: KawasakiWorld.com > Kawasaki World > Off Road

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Forum :: KawasakiWorld.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
kawasaki prairie 650 tmpy11 Off Road 1 02-02-2012 03:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome